Doe not progressing

Discussion in 'Dairy Goat Info' started by Ravens Haven, Apr 20, 2008.

  1. Ravens Haven

    Ravens Haven New Member

    642
    0
    0
    HI all,

    I have a 3 year old doe that was lutalysed 37 hours ago and still nothing at all, I tried to go in to see what was going on but she hasn't loosened nothing, her ligaments seem to be gone but I couldn't get but one finger in her vagina at all couldn't even get to the cervix to see what was going on. We have given her 30 cc calcium what else can I do for her and how often can we give the calcium.

    Thanks
    Autumn
     
  2. MRFBarbara

    MRFBarbara Guest

    Are you sure she is pregnant? Did you give it in the muscle? Did you give 2 cc's?
    Barbara
     

  3. NubianSoaps.com

    NubianSoaps.com New Member

    16,497
    4
    0
    It's usually not a good injection when this happens. I just have never had it go passed 36 hours, although I know others who have. Vicki
     
  4. Ravens Haven

    Ravens Haven New Member

    642
    0
    0
    Well, the doe kidded with vet assistance, he gave 30cc IV calcium and 40cc subq calcium, once the feet and head was past the cervix he gave a shot of oxy and out pops a single (not so big) buck kid. This doe was inherited well after being bred just a few weeks ago, she is hog-fat and that is why nothing was going forth, she was so fat inside we couldn't get our hands in to assist. Guess what she is going on a diet...now....
    This is a brand new bottle of Lute.
    THanks
    Autumn
     
  5. Shykid Acres

    Shykid Acres Guest

    Glad everything came out okay. :lol No pun intended. :lol Congrats on the new kid!
     
  6. Kaye White

    Kaye White Guest

    1,837
    0
    0
    Exactly. If you give it SQ or even in the fat....it either takes forever to work or not at all. Never give hormones SQ. Lute will work WAY past the expiration date...I've used injections that were as much as 5-6 yrs. over and it still worked.
    I'm glad you had a vet give that much calcium.
    Kaye